# JAR 假如你不会使用maven, 又不想花费那么一点点的时间去学习,一意孤行的非得要用jar包导入的方式来构建项目的话,我也没有什么好说的。我将会在这里列举出`核心框架`所需要的所有外部JAR包依赖及其版本。 >[warning] 注①:下列依赖极其版本根据核心`1.6.3`版本时候的情况进行列举。 >[warning] 注②:此处列举的所需依赖仅为`核心框架`所需依赖,其他一切`组件框架`所需的依赖中,除了`核心框架`以外的所有额外依赖请查阅对应组件的说明。 你可以选择自行从各类合法jar文件下载网站或者任何合法手段收集、下载以下依赖,或者可以选择加入QQ群聊从群文件中获取jar文件。 目前 [github仓库]([https://github.com/ForteScarlet/simple-robot-core](https://github.com/ForteScarlet/simple-robot-core))中的 [lib目录]([https://github.com/ForteScarlet/simple-robot-core/tree/master/lib](https://github.com/ForteScarlet/simple-robot-core/tree/master/lib)) 和 [releases]([https://github.com/ForteScarlet/simple-robot-core/releases](https://github.com/ForteScarlet/simple-robot-core/releases)) 中我也提供了所有 `dependencies` 的下载地址。 当然了,我首先推荐你使用`Maven`的方式构建项目。 <br> ## 外部依赖: * `c3p0-0.9.5.2` * `commons-beanutils-1.9.3` * `commons-codec-1.9` * `commons-collections-3.2.2` * `commons-io-2.6` * `commons-logging-1.2` * `console-plus-1.2.1` * `fastjson-1.2.54` * `HikariCP-java6-2.3.13` * `httpclient-4.5` * `httpcore-4.4.4` * `httpmime-4.5` * `mchange-commons-java-0.2.11` * `quartz-2.3.0` * `simple-plusutils-1.3.1` * `slf4j-api-1.7.7` 你可以使用以上依赖的其他版本,只要你能够保证此依赖不同版本之间的兼容性即可。毕竟不兼容的话是没办法执行程序的。